Reward Archives Data Mismatch

Incident Report for Punchh US-West

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 06:51 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 05:57 PST

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 04:19 PST

Investigating

We are currently looking into an issue where some users may notice discrepancies in reporting along with the campaigns. This affects a limited number of campaigns across a few customers. All other services are working normally, and our teams are actively working to restore the functionality.
There can be discrepancies in reporting along with the campaigns for a few customers.
Posted Nov 24, 2025 - 04:12 PST